Το πρόγραμμα

Το πρόγραμμα των Εκλογών 15μελούς Σχολείου v4.0 βοηθάει στην αυτοματοποίηση της εξαγωγής του εκλογικού αποτελέσματος. Αποτελείται από 3 ξεχωριστά τμήματα-εφαρμογές:

  1. Το module του Διαχειριστή. Είναι το κύριο module και το χειρίζεται ο εποπτεύων καθηγητής.

  2. Το module της Εφορευτικής Επιτροπής. Μέσω αυτού, το μέλος της Εφορευτικής Επιτροπής (μαθητής) καταχωρεί τα ψηφοδέλτια.

  3. Το module της On-line ψηφοφορίας. Μέσω αυτού, οι μαθητές μπορούν να ψηφίσουν απ' ευθείας (στο τοπικό δίκτυο του εργαστηρίου Πληροφορικής), χωρίς να χρησιμοποιήσουμε χάρτινα ψηφοδέλτια!

  • Για την καταχώρηση των ψήφων χρησιμοποιούμε είτε το 2ο module είτε το 3o, τα οποία έχουμε εγκαταστήσει στους αντίστοιχους υπολογιστές.

Το παρόν manual αφορά το module της Εφορευτικής Επιτροπής.


Δυνατότητες

Το module της Εφορευτικής Επιτροπής μας επιτρέπει:

  • Να καθορίσουμε πού βρίσκεται το αρχείο της Βάσης Δεδομένων. Το αρχείο της Βάσης Δεδομένων έχει όνομα Ekloges15Melous.accdb και μπορεί να βρίσκεται τοπικά ή σε άλλον υπολογιστή του τοπικού δικτύου.
  • Να γίνει είσοδος του μέλους στο πρόγραμμα, με βάση τους κωδικούς εισόδου που έχουν δημιουργηθεί στο module του Διαχειριστή.
  • Να επιλέξουμε την Ψηφοφορία (Αρχική ή Επαναληπτική).
  • Να καταχωρίσουμε τα ψηφοδέλτια.
  • Να διορθώσουμε, εκ των υστέρων, ένα ψηφοδέλτιο αν έχουμε κάνει λάθος. Π.χ. ένα άκυρο ψηφοδέλτιο αποφασίζεται ότι είναι έγκυρο.
  • Να διαγράψουμε ένα ψηφοδέλτιο, για κάποιο λόγο.


Απαιτήσεις συστήματος

Το module της Εφορευτικής Επιτροπής έχει τις εξής τεχνικές απαιτήσεις συστήματος:

  • Windows XP με Service Pack 3 ή Windows Server 2003 SP2 και άνω.
  • Εγκατεστημένο το .NET Framework 4.0 και άνω. Σε νεώτερα λειτουργικά συστήματα (π.χ. Windows 10) το .NET Framework θα είναι ήδη εγκατεστημένο. Αν όχι, τότε μπορείτε να το κατεβάσετε από εδώ: https://www.microsoft.com/el-GR/download/details.aspx?id=17718
  • Access Database Engine 2010 32-bit ή 64-bit (ανάλογα με το σύστημα). Αν δεν είναι εγκατεστημένη η Access Database Engine, μπορείτε να το κατεβάσετε από εδώ:
    https://www.microsoft.com/en-us/download/details.aspx?id=13255

Στο site, στην ενότητα Details, θα δείτε δύο εκδόσεις: μία για 32-bit και μία για 64-bit. Αν έχετε Windows XP SP3 θα κατεβάσετε την 32-bit ενώ για τα επόμενα Windows, αν είναι Windows 64-bit κατεβάστε την Access Database Engine 64-bit αλλιώς την 32-bit.


Εγκατάσταση

Το module της Εφορευτικής Επιτροπής δεν χρειάζεται εγκατάσταση. Απλά, αντιγράφουμε το φάκελο του προγράμματος στο σκληρό δίσκο και εκτελούμε το πρόγραμμα Ekloges15Melous_Eforeftiki.exe. Εφόσον, πληρούνται οι τεχνικές προϋποθέσεις, θα δούμε την οθόνη εισόδου.

Εφόσον, έχουμε τοπικό δίκτυο, μπορούμε να εγκαταστήσουμε το πρόγραμμα σε αρκετούς υπολογιστές (συνιστάται μέχρι 10). Έτσι, επιταχύνεται η καταχώρηση των ψηφοδελτίων ταυτόχρονα από περισσότερα του ενός μέλη.


Επικοινωνία

Για οποιαδήποτε παρατήρηση ή απορία μπορείτε να επικοινωνήσετε μαζί μου στα:

E-mail: | mouratx@yahoo.com ή mouratx@hotmail.com
Ιστοσελίδα: | http://users.sch.gr/mouratx
LinkedIn: | https://www.linkedin.com/in/christos-mouratidis-513aa268/

Πειραιάς 2019


Εύρεση της Βάσης Δεδομένων

Κατά την είσοδο στην εφαρμογή την πρώτη φορά, πιθανότατα θα δούμε την παρακάτω οθόνη:

Στην περίπτωση αυτή, πατάμε το κουμπί Αναζήτηση της Βάσης... και αναζητούμε το αρχείο Ekloges15Melous.accdb. Αυτό, μπορεί να βρίσκεται τοπικά ή σε κάποιον άλλον υπολογιστή του δικτύου και πρέπει να είναι το ίδιο με αυτό που έχουμε ορίσει και στο module του Διαχειριστή. Τα στοιχεία που θα εμφανίσει εδώ (Σχολείο, Σχολικό Έτος, Μέλη Εφορευτικής κλπ) θα τα "τραβήξει" από τη Βάση.

Στην παρακάτω εικόνα, στο παράθυρο Αναζήτησης της Βάσης, η Βάση βρίσκεται στον υπολογιστή του δικτύου με όνομα Client02. Ο φάκελος Εκλογές15μελούς_Data έχει οριστεί μοιραζόμενος (shared) και ως εκ τούτου είναι ορατός στο τοπικό δίκτυο:

Αφού επιλέξουμε τον φάκελο, εμφανίζεται το αρχείο της Βάσης Ekloges15Melous.accdb. Το επιλέγουμε και πατάμε το κουμπί Άνοιγμα:

Αφού η Βάση Δεδομένων βρέθηκε τότε εμφανίζεται ενδεικτικά η παρακάτω εικόνα:

Αν πάμε το ποντίκι πάνω από το πράσινο μήνυμα Η Βάση Δεδομένων βρέθηκε θα δούμε ένα κίτρινο tooltip που μας εμφανίζει τη διαδρομή (path) του αρχείου της Βάσης. Η παρακάτω εικόνα είναι από ένα σύστημα με Windows XP:

Το κουμπί Συνέχεια >> ενεργοποιείται. Είμαστε έτοιμοι να περάσουμε στην επόμενη οθόνη εισόδου του μέλους της Εφορευτικής.

Σημ.1: Το πρόγραμμα "θυμάται" πού βρίσκεται η Βάση Δεδομένων. Έτσι, την επόμενη φορά που θα μπούμε στο πρόγραμμα θα πατήσουμε απ' ευθείας το κουμπί Συνέχεια >>. Αν βέβαια, αλλάξουμε την τοποθεσία της Βάσης πρέπει να πατήσουμε τον σύνδεσμο Αλλαγή... και να την αναζητήσουμε εκ νέου.

Σημ.2: Αν αφήσουμε το ποντίκι πάνω από το μήνυμα "Η Βάση Δεδομένων βρέθηκε" , θα δούμε έναν ενημερωτικό tooltip που αναφέρει την ακριβή τοποθεσία (path) της Βάσης.


Είσοδος μέλους Εφορευτικής

H οθόνη εισόδου του μέλους της Εφορευτικής φαίνεται ενδεικτικά στην παρακάτω εικόνα:

Στο πάνω μέρος του παραθύρου φαίνονται τα στοιχεία του Σχολείου και του Σχολικού Έτους. Αυτά ορίζονται μέσω του module του Διαχειριστή και αυτόματα εμφανίζονται εδώ (εφόσον, βέβαια, έχουμε βρει την τοποθεσία της Βάσης από το προηγούμενο βήμα).

Στο κύριο τμήμα του παραθύρου εισόδου:

- Στο πεδίο Ονοματεπώνυμο : Επιλέγουμε από τη λίστα ποιό είναι το Ονοματεπώνυμο του μέλους της Εφορευτικής που θα καταχωρεί τα ψηφοδέλτια. Τα ονοματεπώνυμα, λαμβάνονται από τη Βάση κι εμφανίζονται αυτόματα.

- Στο πεδίο Κωδικός: Το μέλος της Εφορευτικής δίνει τον κωδικό του, όπως έχει καθοριστεί στο module του Διαχειριστή. Θα τον προμηθεύσει ο Διαχειριστής (συνήθως, ο εποπτεύων Καθηγητής/τρια). Κατά την πληκτρολόγηση εμφανίζονται κουκκίδες.

- Στο πεδίο Ψηφοφορία: Επιλέγουμε για ποιά ψηφοφορία (Αρχική ή Επαναληπτική) θα γίνει καταχώρηση ψηφοδελτίων. Στην παραπάνω εικόνα είναι η Αρχική, οπότε εμφανίζεται δίπλα η ένδειξη Εκκρεμής. Αν η κατάσταση της ψηφοφορίας είναι Κλειδωμένη ή Ολοκληρώθηκε δεν μπορούμε να προχωρήσουμε.

Στην παρακάτω εικόνα, επιλέγουμε την μαθήτρια ΣΤΑΜΑΤΟΠΟΥΛΟΥ ΜΑΡΚΕΛΛΑ:

Δίνουμε τον κωδικό κι εφόσον είναι σωστός, ενεργοποιείται το κουμπί Είσοδος>>.

Πατάμε το κουμπί Είσοδος>> και τότε μπαίνουμε στην κύρια οθόνη καταχώρησης ψηφοδελτίων. Παράλληλα, το ονοματεπώνυμο του μέλους της Εφορευτικής εμφανίζεται στο πάνω μέρος του παραθύρου.

Επίσης, ενεργοποιείται το κουμπί Αποσύνδεση στο πάνω δεξί μέρος του παραθύρου, ώστε να μπορεί να αποσυνδεθεί το τρέχον μέλος και να γυρίσει σε αυτήν την οθόνη για να εισέλθει άλλο μέλος.

Σημ.: Αν για κάποιο λόγο, γίνει κάποια τροποποίηση στο module του Διαχειριστή, που επηρεάζει τα στοιχεία που λαμβάνει το πρόγραμμα αυτόματα από τη Βάση (π.χ. τρέχον Σχολείο, τρέχον Σχολικό Έτος, ονοματεπώνυμο μέλους, κωδικός εισόδου μέλους, κατάσταση ψηφοφορίας) τότε πρέπει να βγούμε από το πρόγραμμα (Έξοδος) και να ξαναμπούμε.


Προετοιμασία

Προετοιμασία - Αρίθμηση Ψηφοδελτίων

Πριν ξεκινήσει η ηλεκτρονική καταχώρηση των ψηφοδελτίων, απαιτείται να γίνει μία μικρή προετοιμασία.

Τα ψηφοδέλτια είναι συγκεντρωμένα σε μία κάλπη. Δύο μέλη της Εφορευτικής αναλαμβάνουν να βγάλουν σταδιακά τα ψηφοδέλτια από την κάλπη και να τα αριθμήσουν ξεκινώντας από το 1. Ο αριθμός του ψηφοδελτίου απαιτείται από το πρόγραμμα κατά την καταχώρηση.

Μόλις αριθμηθούν μερικά, για να μη χαθεί χρόνος, μπορεί να ξεκινήσει άμεσα η ηλεκτρονική καταχώρηση από τα υπόλοιπα μέλη. Αν έχουμε τοπικό δίκτυο, μπορούν να καθίσουν τα μέλη και να καταχωρούν ταυτόχρονα από διαφορετικούς υπολογιστές, ενώ η αρίθμηση μπορεί να συνεχίζεται.

Σημ.: Κατά την αρίθμηση των ψηφοδελτίων, ιδιαίτερη προσοχή να δοθεί στους αριθμούς 6, 66, 9, 99, 86, 98, υπογραμμίζοντάς τους για να μην υπάρξει σύγχυση.


Η οθόνη καταχώρησης ψηφοδελτίων

Μετά την είσοδο του μέλους της Εφορευτικής Επιτροπής, και την επιλογή για Αρχική ή Επαναληπτική ψηφοφορία, εμφανίζεται η κύρια οθόνη της εφαρμογής που είναι η οθόνη καταχώρησης ψηφοδελτίων.

Για Αρχική Ψηφοφορία

Στην παρακάτω εικόνα, εμφανίζεται η οθόνη για την Αρχική Ψηφοφορία.

Για Επαναληπτική Ψηφοφορία

Στο ψηφοδέλτιο της Επαναληπτικής υπάρχουν δύο τμήματα: Ένα για τους ισοψηφήσαντες στα Τακτικά μέλη και ένα για τους ισοψηφήσαντες στα Αναπληρωματικά μέλη. Βέβαια, αν υπάρχουν ισοψηφήσαντες στο αντίστοιχο τμήμα. Παρόμοια, εδώ η οθόνη καταχώρησης έχει δύο πεδία: Ένα για τον σταυρό για το Τακτικό μέλος και ένα για τον σταυρό για το Αναπληρωματικό μέλος. Αν δεν υπάρχουν ισοψηφήσαντες σε κάποιο τμήμα, το αντίστοιχο πεδίο σταυρού δεν θα εμφανίζεται.

Στην παρακάτω εικόνα, εμφανίζεται η οθόνη για την Επαναληπτική Ψηφοφορία, όπου υπάρχουν ισοψηφήσαντες στα Τακτικά και Αναπληρωματικά μέλη:

  • Το αριστερό τμήμα εμφανίζει τους αριθμούς των Ψηφοδελτίων που καταχωρήθηκαν από το συγκεκριμένο μέλος της Εφορευτικής Επιτροπής. Βέβαια, κατά την καταχώρηση οι αριθμοί μπορεί να είναι αταξινόμητοι αλλά πατώντας το κουμπί Ανανέωση γίνεται αύξουσα ταξινόμηση.
  • Στο δεξί τμήμα γίνεται η προσθήκη, διόρθωση και διαγραφή ενός ψηφοδελτίου.

Προσθήκη ψηφοδελτίου

Διόρθωση ψηφοδελτίου

Διαγραφή ψηφοδελτίου

Σημ.: Αν το τρέχον μέλος αποσυνδεθεί με το κουμπί Αποσύνδεση και εισέλθει κάποιος άλλος τότε στο αριστερό μέρος θα εμφανιστούν τα ψηφοδέλτια που έχει καταχωρήσει ο δεύτερος (αν είχε προηγουμένως καταχωρήσει). Με αυτόν τον τρόπο, επίσης, βλέπουμε ποιό μέλος έχει καταχωρίσει τα δικά του ψηφοδέλτια.


Προσθήκη ψηφοδελτίου

Για να εισάγουμε ένα νέο ψηφοδέλτιο κάνουμε τα εξής:

1) Στην οθόνη καταχώρησης ψηφοδελτίων, πατάμε το κουμπί

2) Η φόρμα μπαίνει σε κατάσταση προσθήκης. Τα πεδία παρακάτω, ενεργοποιούνται:

Νο Ψηφοδελτίου: | Δίνουμε τον αριθμό του ψηφοδελτίου, όπως τον έχει γράψει το μέλος της Εφορευτικής, κατά την προετοιμασία-αρίθμηση των ψηφοδελτίων.
Είναι έγκυρο; | Τσεκάρουμε αν είναι έγκυρο. Εξ΄ ορισμού είναι τσεκαρισμένο. Αν το ψηφοδέλτιο είναι άκυρο τότε βγάζουμε το τσεκ και τα υπόλοιπα πεδία (1ος σταυρός κλπ) απενεργοποιούνται.
1ο σταυρός, 2ος σταυρός κλπ. | Στα πεδία αυτά δίνουμε τον αριθμό του υποψηφίου που έχει σταυρό. Φυσικά, μπορούμε να δώσουμε από 1 έως και 7 αριθμούς υποψηφίων. Το πρόγραμμα ελέγχει αυτόματα αν είναι έγκυρος, δηλαδή βρίσκεται στο καθορισμένο εύρος (π.χ. για 57 υποψηφίους θα είναι από 1 έως 57). Επίσης, ελέγχει αν έχει δοθεί δύο ή περισσότερες φορές ο ίδιος αριθμός υποψηφίου. Αν το ψηφοδέλτιο είναι λευκό τότε βάζουμε 0 σε όλα τα πεδία του σταυρού.
κουμπί Αποθήκευση | Αποθηκεύει το ψηφοδέλτιο στη Βάση. Ταυτόχρονα, ενημερώνει αριστερά τη λωρίδα των καταχωρημένων ψηφοδελτίων (από το συγκεκριμένο μέλος) με το νέο ψηφοδέλτιο.
κουμπί Ακύρωση | Ακυρώνει την προσθήκη.

3) Στην παρακάτω εικόνα, έχουμε συμπληρώσει το ψηφοδέλτιο με Νο 35:

4) Έχοντας πατήσει το κουμπί Αποθήκευση, βλέπουμε τη λωρίδα αριστερά να περιλαμβάνει το εισηγμένο ψηφοδέλτιο:

Δίπλα στο κουμπί Αποθήκευση εμφανίζεται το σύμβολο

5) Επαναλαμβάνουμε τη διαδικασία από το βήμα 1.

Παρόμοια, είναι η διαδικασία προσθήκης ψηφοδελτίου Επαναληπτικής. Στην παρακάτω εικόνα, εισάγουμε το ψηφοδέλτιο Νο 12:

Το ψηφοδέλτιο έχει έναν σταυρό για Τακτικό μέλος στον Υποψήφιο με αριθμό 19, κι έναν σταυρό για Αναπληρωματικό μέλος στον Υποψήφιο με αριθμό 3.

Σημ.: Στη λωρίδα καταχωρημένων ψηφοδελτίων αριστερά, τα ψηφοδέλτια εμφανίζονται κατά τη σειρά εισαγωγής τους. Αν επιθυμούμε να εμφανίζονται ταξινομημένα κατά Νο ψηφοδελτίου πατάμε το κουμπί Ανανέωση.


Διόρθωση ψηφοδελτίου

Για να διορθώσουμε ένα ψηφοδέλτιο κάνουμε τα εξής:

1) Στην οθόνη καταχώρησης ψηφοδελτίων, στη λωρίδα καταχωρημένων ψηφοδελτίων αριστερά, επιλέγουμε το ψηφοδέλτιο.

Στην παρακάτω εικόνα, κάνουμε κλικ στο ψηφοδέλτιο Νο 4, οπότε εμφανίζονται δεξιά τα στοιχεία του:

Στο ψηφοδέλτιο αυτό ξεχάστηκε να περαστεί ο 7ος σταυρός.

2) Πατάμε το κουμπί [image]. Η φόρμα μπαίνει σε κατάσταση διόρθωσης. Τα πεδία παρακάτω, ενεργοποιούνται. Στην παρακάτω εικόνα, έχουμε πάει ήδη στο πεδίο 7ος σταυρός.

3) Κάνουμε τη διόρθωση των στοιχείων. Στην παρακάτω εικόνα, βάζουμε τον αριθμό 55 στο πεδίο 7ος σταυρός και πατάμε το κουμπί Αποθήκευση:

4) Η λωρίδα καταχωρημένων ψηφοδελτίων αριστερά ενεργοποιείται ξανά. Επίσης, δίπλα στο κουμπί Αποθήκευση εμφανίζεται το σύμβολο

Παρόμοια, είναι η διαδικασία διόρθωσης ψηφοδελτίου Επαναληπτικής.

Σημ.: Στη λωρίδα καταχωρημένων ψηφοδελτίων αριστερά, τα ψηφοδέλτια εμφανίζονται κατά τη σειρά εισαγωγής τους. Αν επιθυμούμε να εμφανίζονται ταξινομημένα κατά Νο ψηφοδελτίου πατάμε το κουμπί Ανανέωση.


Διαγραφή ψηφοδελτίου

Για να διαγράψουμε ένα ψηφοδέλτιο κάνουμε τα εξής:

1) Στην οθόνη καταχώρησης ψηφοδελτίων, στη λωρίδα καταχωρημένων ψηφοδελτίων αριστερά, επιλέγουμε το ψηφοδέλτιο.

Στην παρακάτω εικόνα, κάνουμε κλικ στο ψηφοδέλτιο Νο 22, οπότε εμφανίζονται δεξιά τα στοιχεία του:

2) Πατάμε το κουμπί [image]. Εμφανίζεται το παράθυρο επιβεβαίωσης διαγραφής:

3) Πατάμε το κουμπί Yes.

Η λωρίδα καταχωρημένων ψηφοδελτίων αριστερά ενημερώνεται και αυτόματα επιλέγεται το επόμενο διαθέσιμο ψηφοδέλτιο:

Παρόμοια, είναι η διαδικασία διαγραφής ψηφοδελτίου Επαναληπτικής.

Σημ.: Στη λωρίδα καταχωρημένων ψηφοδελτίων αριστερά, τα ψηφοδέλτια εμφανίζονται κατά τη σειρά εισαγωγής τους. Αν επιθυμούμε να εμφανίζονται ταξινομημένα κατά Νο ψηφοδελτίου πατάμε το κουμπί Ανανέωση.