Το πρόγραμμα

Το πρόγραμμα των Εκλογών 15μελούς Σχολείου v4.0 βοηθάει στην αυτοματοποίηση της εξαγωγής του εκλογικού αποτελέσματος. Αποτελείται από 3 ξεχωριστά τμήματα-εφαρμογές:

  1. Το module του Διαχειριστή. Είναι το κύριο module και το χειρίζεται ο εποπτεύων καθηγητής.

  2. Το module της Εφορευτικής Επιτροπής. Μέσω αυτού, το μέλος της Εφορευτικής Επιτροπής (μαθητής) καταχωρεί τα ψηφοδέλτια.

  3. Το module της On-line ψηφοφορίας. Μέσω αυτού, οι μαθητές μπορούν να ψηφίσουν απ' ευθείας (στο τοπικό δίκτυο του εργαστηρίου Πληροφορικής), χωρίς να χρησιμοποιήσουμε χάρτινα ψηφοδέλτια!

  • Για την καταχώρηση των ψήφων χρησιμοποιούμε είτε το 2ο module είτε το 3o, τα οποία έχουμε εγκαταστήσει στους αντίστοιχους υπολογιστές.

Το παρόν manual αφορά το module της On-line ψηφοφορίας.


Δυνατότητες

Το module της On-line Ψηφοφορίας μας επιτρέπει:

  • Να καθορίσουμε πού βρίσκεται το αρχείο της Βάσης Δεδομένων. Το αρχείο της Βάσης Δεδομένων έχει όνομα Ekloges15Melous.accdb και μπορεί να βρίσκεται τοπικά ή σε άλλον υπολογιστή του τοπικού δικτύου.
  • Να επιλέξουμε την Ψηφοφορία (Αρχική ή Επαναληπτική).
  • Να γίνει είσοδος του μαθητή-ψηφοφόρου, με βάση τον τετραψήφιο κωδικό (PIN) που του έχει δώσει απόρρητα η Εφορευτική Επιτροπή. Οι κωδικοί αυτοί έχουν δημιουργηθεί στο module του Διαχειριστή.
  • Να επιλέξει τους Υποψηφίους που επιθυμεί στο Ψηφοδέλτιο της οθόνης και να το υποβάλλει. Η υποβολή σημαίνει αποθήκευση στη Βάση Δεδομένων. Μετά την υποβολή αχρηστεύεται το PIN.
  • Μετά την υποβολή γίνεται αυτόματα έξοδος και η οθόνη επανέρχεται στην οθόνη εισόδου για να υποδεχθεί τον επόμενο μαθητή-ψηφοφόρο.


Απαιτήσεις συστήματος

Το module της On-line Ψηφοφορίας έχει τις εξής τεχνικές απαιτήσεις συστήματος:

  • Windows XP με Service Pack 3 ή Windows Server 2003 SP2 και άνω.
  • Εγκατεστημένο το .NET Framework 4.0 και άνω. Σε νεώτερα λειτουργικά συστήματα (π.χ. Windows 10) το .NET Framework θα είναι ήδη εγκατεστημένο. Αν όχι, τότε μπορείτε να το κατεβάσετε από εδώ: https://www.microsoft.com/el-GR/download/details.aspx?id=17718
  • Access Database Engine 2010 32-bit ή 64-bit (ανάλογα με το σύστημα). Αν δεν είναι εγκατεστημένη η Access Database Engine, μπορείτε να το κατεβάσετε από εδώ:
    https://www.microsoft.com/en-us/download/details.aspx?id=13255

Στο site, στην ενότητα Details, θα δείτε δύο εκδόσεις: μία για 32-bit και μία για 64-bit. Αν έχετε Windows XP SP3 θα κατεβάσετε την 32-bit ενώ για τα επόμενα Windows, αν είναι Windows 64-bit κατεβάστε την Access Database Engine 64-bit αλλιώς την 32-bit.


Εγκατάσταση

Το module της On-line Ψηφοφορίας δεν χρειάζεται εγκατάσταση. Απλά, αντιγράφουμε το φάκελο του προγράμματος στο σκληρό δίσκο και εκτελούμε το πρόγραμμα Ekloges15Melous_OnlineVoting.exe. Εφόσον, πληρούνται οι τεχνικές προϋποθέσεις, θα δούμε την οθόνη εισόδου.

Εφόσον, έχουμε τοπικό δίκτυο, μπορούμε να εγκαταστήσουμε το πρόγραμμα σε αρκετούς υπολογιστές (συνιστάται μέχρι 10). Έτσι, μπορούν να ψηφίζουν ταυτόχρονα πολλοί μαθητές.


Επικοινωνία

Για οποιαδήποτε παρατήρηση ή απορία μπορείτε να επικοινωνήσετε μαζί μου στα:

E-mail: | mouratx@yahoo.com ή mouratx@hotmail.com
Ιστοσελίδα: | http://users.sch.gr/mouratx
LinkedIn: | https://www.linkedin.com/in/christos-mouratidis-513aa268/

Πειραιάς 2019


Εύρεση της Βάσης Δεδομένων

Κατά την είσοδο στην εφαρμογή την πρώτη φορά, πιθανότατα θα δούμε την παρακάτω οθόνη:

Στην περίπτωση αυτή, πατάμε το κουμπί Αναζήτηση της Βάσης... και αναζητούμε το αρχείο Ekloges15Melous.accdb. Αυτό, μπορεί να βρίσκεται τοπικά ή σε κάποιον άλλον υπολογιστή του δικτύου και πρέπει να είναι το ίδιο με αυτό που έχουμε ορίσει και στο module του Διαχειριστή. Τα στοιχεία που θα εμφανίσει εδώ (Σχολείο, Σχολικό Έτος, Ψηφοφορία κλπ) θα τα "τραβήξει" από τη Βάση.

Στην παρακάτω εικόνα, στο παράθυρο Αναζήτησης της Βάσης, η Βάση βρίσκεται στον υπολογιστή του δικτύου με όνομα Client02. Ο φάκελος Εκλογές15μελούς_Data έχει οριστεί μοιραζόμενος (shared) και ως εκ τούτου είναι ορατός στο τοπικό δίκτυο:

Αφού επιλέξουμε τον φάκελο, εμφανίζεται το αρχείο της Βάσης Ekloges15Melous.accdb. Το επιλέγουμε και πατάμε το κουμπί Άνοιγμα:

Αφού η Βάση Δεδομένων βρέθηκε τότε εμφανίζεται ενδεικτικά η παρακάτω εικόνα:

Αν πάμε το ποντίκι πάνω από το πράσινο μήνυμα Η Βάση Δεδομένων βρέθηκε θα δούμε ένα κίτρινο tooltip που μας εμφανίζει τη διαδρομή (path) του αρχείου της Βάσης:

Επιλέγουμε την Ψηφοφορία. Στην προκειμένη περίπτωση, επιλέγουμε την Αρχική, που η κατάστασή της είναι Εκκρεμής. Παράλληλα, το κουμπί Συνέχεια>> ενεργοποιείται. Είμαστε έτοιμοι να περάσουμε στην επόμενη οθόνη εισόδου για τον μαθητή που θα ψηφίσει.

Σημ.1: Το πρόγραμμα "θυμάται" πού βρίσκεται η Βάση Δεδομένων. Έτσι, την επόμενη φορά που θα μπούμε στο πρόγραμμα, θα επιλέξουμε την Ψηφοφορία (Αρχική ή Επαναληπτική) και θα πατήσουμε απ' ευθείας το κουμπί Συνέχεια >>. Αν βέβαια, αλλάξουμε την τοποθεσία της Βάσης πρέπει να πατήσουμε τον σύνδεσμο Αλλαγή... και να την αναζητήσουμε εκ νέου.

Σημ.2: Αν αφήσουμε το ποντίκι πάνω από το μήνυμα "Η Βάση Δεδομένων βρέθηκε" , θα δούμε έναν ενημερωτικό tooltip που αναφέρει την ακριβή τοποθεσία (path) της Βάσης.

Σημ.3: Το βήμα της Εύρεσης της Βάσης Δεδομένων προτείνεται να γίνει από τον Διαχειριστή.


Είσοδος μαθητή

Στάδιο 1: Έλεγχος από την Εφορευτική Επιτροπή

Στο στάδιο αυτό πρέπει να γίνει ο έλεγχος του μαθητή από την Εφορευτική Επιτροπή:

  1. Ο μαθητής-ψηφοφόρος εισέρχεται στην αίθουσα και κατευθύνεται στην Εφορευτική Επιτροπή.
  2. Η Εφορευτική, με βάση τον αλφαβητικό κατάλογο τάξης ή τμήματος, επιβεβαιώνει τον μαθητή και τον σημειώνει ότι παρουσιάστηκε.
  3. Η Εφορευτική του δίνει απόρρητα το χαρτάκι με τον κωδικό εισόδου (PIN) και τον κατευθύνει σε διαθέσιμο υπολογιστή για να ψηφίσει.

Συνιστάται, οι μαθητές να εισέρχονται στην αίθουσα σταδιακά ανά τμήμα ή τάξη, ώστε να γίνεται ευκολότερα ο έλεγχος.

Στάδιο 2: Πηγαίνει σε έναν υπολογιστή και κάνει είσοδο στο πρόγραμμα

Στην οθόνη εισόδου, ο μαθητής πρέπει να δώσει τον κωδικό του (τετραψήφιος PIN), όπως φαίνεται στην παρακάτω εικόνα:

Ο κωδικός εισόδου βρίσκεται στο χαρτάκι που του έχει δώσει απόρρητα η Εφορευτική Επιτροπή κατά την προσέλευσή του στην αίθουσα των υπολογιστών, όπου πραγματοποιείται η ηλεκτρονική ψηφοφορία.

Ο μαθητής ξεδιπλώνει το χαρτάκι, διαβάζει τον κωδικό και τον συμπληρώνει στο αντίστοιχο πεδίο, όπως φαίνεται στην παρακάτω εικόνα:

Στη θέση κάθε ψηφίου του PIN εμφανίζεται αντίστοιχη κουκκίδα. Εφόσον ο μαθητής συμπληρώσει επιτυχώς τον έγκυρο κωδικό του, το κουμπί Είσοδος>> ενεργοποιείται. Πατώντας, λοιπόν, το κουμπί Είσοδος>> μεταβαίνει στην οθόνη καταχώρησης ψηφοδελτίου.

Σημ.: Μόλις ο μαθητής καταχωρήσει (υποβάλλει) επιτυχώς το ψηφοδέλτιό του, ο κωδικός εισόδου αχρηστεύεται. Παράλληλα, το πρόγραμμα επιστρέφει στην οθόνη εισόδου και περιμένει τον επόμενο μαθητή να ψηφίσει.


Η οθόνη καταχώρησης ψηφοδελτίου

Σε αυτήν την οθόνη ο μαθητής θα ψηφίσει.

Αρχική Ψηφοφορία

Στην παρακάτω εικόνα, εμφανίζεται ένα ψηφοδέλτιο που αφορά την Αρχική Ψηφοφορία:

Η οθόνη χωρίζεται στα εξής τμήματα:

  • Αριστερά είναι το ψηφοδέλτιο. Παρουσιάζει αλφαβητικά τους Υποψηφίους. Θα χρειαστεί να κυλήσει προς τα κάτω τη λίστα για να δει και τους υπόλοιπους. Εδώ, ο μαθητής θα επιλέξει μέχρι και 7 ονόματα.
  • Στο δεξί τμήμα, στο πάνω μέρος υπάρχουν σχετικές οδηγίες.
  • Στο δεξί τμήμα, στη μέση θα εμφανίζονται οι επιλεγμένοι Υποψήφιοι (καθώς και πόσοι έχουν επιλεγεί στην παρένθεση)
  • Στο δεξί τμήμα, στο κάτω μέρος βρίσκονται τα κουμπιά Υποβολή και Ακύρωση και Έξοδος.

Για να ψηφίσει ο μαθητής κάνει κλικ πάνω σε ένα όνομα. Ταυτόχρονα, στο δεξί μέρος εμφανίζονται ποιοί έχουν επιλεγεί, ώστε να ξέρει ο μαθητής ποιούς και πόσους έχει ψηφίσει μέχρι στιγμής.

Στην παρακάτω εικόνα, έχουμε κάνει κλικ σε κάποια ονόματα (μερικά εκ των οποίων φαίνονται με σταυρό στην εικόνα):

Αν ο μαθητής θέλει να ακυρώσει κάποια επιλογή τότε ξανακάνει κλικ στο όνομα και αφαιρείται από τους επιλεγμένους.

Σε περίπτωση που επιλέξει περισσότερους από 7, τότε η λίστα των επιλεγμένων στο δεξί μέρος εμφανίζει σε παρένθεση με κόκκινο χρώμα τον αριθμό των επιλεγμένων, όπως φαίνεται στην παρακάτω εικόνα:

Παράλληλα, αν προσπαθήσει να υποβάλλει το ψηφοδέλτιο, το πρόγραμμα δεν θα τον αφήσει και θα του εμφανίσει το μήνυμα λάθους:

Φυσικά, ο μαθητής μπορεί να μην επιλέξει κανένα όνομα και να υποβάλλει κανονικά το ψηφοδέλτιο. Στην περίπτωση αυτή προσμετράται ως λευκό.

Στο τέλος, ο μαθητής πατάει το κουμπί Υποβολή. Εμφανίζεται ένα παράθυρο επιβεβαίωσης υποβολής:

Πατάει το κουμπί Yes. Το ψηφοδέλτιο καταχωρείται, δηλαδή αποθηκεύεται στη Βάση Δεδομένων και το πρόγραμμα του εμφανίζει ένα ευχαριστήριο μήνυμα, όπως παρακάτω:

Μόλις πατήσει το κουμπί Έξοδος, το πρόγραμμα επιστρέφει στην οθόνη εισόδου για να υποδεχθεί τον επόμενο μαθητή.

Ο μαθητής αποχωρεί από την αίθουσα. Εφόσον ψήφισε κανονικά, ο κωδικός εισόδου που χρησιμοποίησε αχρηστεύθηκε.

Επαναληπτική Ψηφοφορία

Στην παρακάτω εικόνα, εμφανίζεται ένα ψηφοδέλτιο που αφορά την Επαναληπτική Ψηφοφορία με 3 ισοψηφήσαντες για Τακτικά και Αναπληρωματικά μέλη:

Η οθόνη χωρίζεται στα εξής τμήματα:

  • Αριστερά είναι το ψηφοδέλτιο χωρισμένο σε 2 τμήματα (Για Τακτικό / Για Αναπληρωματικό μέλος). Παρουσιάζει αλφαβητικά τους Υποψηφίους σε κάθε τμήμα. Εδώ, ο μαθητής θα επιλέξει 1 όνομα από κάθε τμήμα. Βέβαια, αν δεν έχουμε ισοψηφήσαντες σε κάποιο τμήμα, αυτό δεν θα εμφανίζεται.
  • Στο δεξί τμήμα, στο πάνω μέρος υπάρχουν σχετικές οδηγίες.
  • Στο δεξί τμήμα, στη μέση θα εμφανίζονται οι επιλεγμένοι Υποψήφιοι, για κάθε τμήμα.
  • Στο δεξί τμήμα, στο κάτω μέρος βρίσκονται τα κουμπιά Υποβολή και Ακύρωση και Έξοδος.

Για να ψηφίσει ο μαθητής κάνει κλικ πάνω σε ένα όνομα, σε κάθε τμήμα. Ταυτόχρονα, στο δεξί μέρος εμφανίζεται ποιός έχει επιλεγεί, ώστε να ξέρει ο μαθητής ποιόν έχει ψηφίσει μέχρι στιγμής από κάθε τμήμα.

Στην παρακάτω εικόνα, έχουμε κάνει κλικ σε 2 ονόματα, έναν σε κάθε τμήμα:

Εδώ, αν ο μαθητής θέλει να ακυρώσει την επιλογή του και να ψηφίσει κάποιον άλλον, τότε απλά κάνει κλικ στον άλλον Υποψήφιο (στο ίδιο τμήμα). Το πρόγραμμα, αυτόματα ακυρώνει την προηγούμενη επιλογή και "σταυρώνει" την νέα.

Στη συνέχεια, όπως και στην Αρχική Ψηφοφορία, ο μαθητής πατάει το κουμπί Υποβολή, εμφανίζεται ένα παράθυρο επιβεβαίωσης της υποβολής και αν πατήσει το κουμπί Yes, το ψηφοδέλτιο καταχωρείται κι εμφανίζεται το ευχαριστήριο μήνυμα. Πατώντας το κουμπί Έξοδος, το πρόγραμμα επιστρέφει στην οθόνη εισόδου για να υποδεχθεί τον επόμενο μαθητή.

Ο μαθητής αποχωρεί από την αίθουσα. Εφόσον ψήφισε κανονικά, ο κωδικός εισόδου που χρησιμοποίησε αχρηστεύθηκε.

Σημ.1: Αν ο μαθητής πατήσει το κουμπί Ακύρωση και Έξοδος τότε εμφανίζεται ένα παράθυρο επιβεβαίωσης εξόδου και αν πατήσει το Yes, επιστρέφει στην οθόνη εισόδου. Τότε είτε ξαναδοκιμάζει με τον κωδικό του είτε εγκαταλείπει, για κάποιο λόγο, την αίθουσα χωρίς να ψηφίσει.

Σημ.2: Η εμφάνιση του ευχαριστήριου μηνύματος σημαίνει ότι πράγματι το ψηφοδέλτιο καταχωρήθηκε χωρίς πρόβλημα στη Βάση Δεδομένων. Παράλληλα, σημαίνει ότι αχρηστεύθηκε και ο κωδικός εισόδου (PIN) που χρησιμοποίησε.

Σημ.3: Συνιστάται να είναι μεγιστοποιημένο το παράθυρο της οθόνης καταχώρησης.