Υποστήριξη έκδοσης PHP 7.4 στις Ιστοσελίδες στο ΠΣΔ

Κατόπιν ενημέρωσης από το Πανελλήνιο Σχολικό Δίκτυο, στους Web Servers του λειτουργεί πλέον και η έκδοση 7.4.x της PHP. Ο κύριος λόγος αναβάθμισης της PHP είναι η μη υποστήριξη πλέον των προηγούμενων εκδόσεων (http://www.php.net/eol.php).

Προσοχή!!! Η ενημέρωση αφορά μόνο τους χρήστες οι οποίοι έχουν δικτυακό τόπο στο Πανελλήνιο Σχολικό Δίκτυο (ΠΣΔ) στην παλιά υποδομή και όχι στην νέα που λειτουργεί με χρήση του PLESK.

Καθώς στους ιστοτόπους των χρηστών εξακολουθεί να λειτουργεί ως  βασική έκδοση της PHP η 5.6, θα πρέπει προκειμένου να ενεργοποιηθεί η έκδοση 7.4.x, να δημιουργηθεί στον φάκελο στον οποίο είναι εγκατεστημένο το CMS, το αρχείο .htaccess με το ακόλουθο περιεχόμενο:

AddHandler php74 .php

Ανάλογη διαδικασία ισχύει για χρήση της PHP έκδοσης 7.2.x, όπου η παραπάνω εντολή διαμορφώνεται ως εξής:

AddHandler php72 .php

Επισημαίνεται ότι ιστότοποι που βασίζονται σε παλιά έκδοση CMS (π. χ. Joomla 1.5 ή Joomla 2.5 ) και λειτουργούν με την έκδοση 5.6.x  της PHP θα πρέπει άμεσα να αναβαθμιστούν καθώς γίνονται στόχος κακόβουλων επιθέσεων, με αποτέλεσμα την αλλοίωσή τους και κατ’ επέκταση τη δυσλειτουργία των διακομιστών που τις φιλοξενούν.

Σε περίπτωση που εντοπίσετε κάποια αλλοίωση μπορείτε να ενημερώσετε μέσω του πληροφοριακού μας συστήματος Helpdesk ΠΣΔ που λειτουργεί στην διεύθυνση http://helpdesk.sch.gr.

Share
Share