Home Λύκειο ΑΕΠΠ Βασικά σημεία ΑΕΠΠ κλιμακωτή κλιμακούμενη

ΑΕΠΠ κλιμακωτή κλιμακούμενη

 

[Κλιμακωτή]

Η HoeL-telefon χρεώνει κλιμακωτά τους πελάτες της για τις υπηρεσίες σταθερής τηλεφωνίας σύμφωνα με τον πίνακα:

Μονάδες Χρέωση (€ ανά μονάδα)..........

 

Η HoeL-telefon χρεώνει κλιμακωτά τους πελάτες της για τις υπηρεσίες σταθερής τηλεφωνίας σύμφωνα με τον πίνακα:

Μονάδες Χρέωση (€ ανά μονάδα)

0 – 120 0.10

121 – 260 0.08

261 – 400 0.06

401 και άνω 0.03

Το πάγιο τέλος χρήσης των υπηρεσιών είναι 10€ μηνιαίως, ενώ το συνολικό ποσό υπόκειται σε φόρο 2% για τέλη τηλεπικοινωνιών και 19% ΦΠΑ. Να αναπτυχθεί πρόγραμμα που θα διαβάζει το όνομα ενός συνδρομητή, τις τηλεφωνικές μονάδες που κατανάλωσε και να εκτυπώνει το ποσό του λογαριασμού

Λύση

ΠΡΟΓΡΑΜΜΑ HoeL-telefon

ΣΤΑΘΕΡΕΣ

πάγιο = 10

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: μονάδες

ΠΡΑΓΜΑΤΙΚΕΣ: χρέωση, φόρος, ΦΠΑ

ΧΑΡΑΚΤΗΡΕΣ: όνομα

ΑΡΧΗ

ΔΙΑΒΑΣΕ όνομα, μονάδες

ΑΝ μονάδες <= 120 ΤΟΤΕ

χρέωση <- πάγιο + 0.10 * μονάδες

ΑΛΛΙΩΣ_ΑΝ μονάδες <= 260 ΤΟΤΕ

χρέωση <- πάγιο + 0.10 * 120 + 0.08 * (μονάδες – 120)

ΑΛΛΙΩΣ_ΑΝ μονάδες <= 400 ΤΟΤΕ

χρέωση <- πάγιο + 0.10 * 120 + 0.08 * 140 + 0.06 * (μονάδες – 260)

ΑΛΛΙΩΣ ! μονάδες > 400

χρέωση <- πάγιο + 0.10 * 120 + 0.08 * 140 + 0.06 * 140 + 0.03 * (μονάδες – 400)

ΤΕΛΟΣ_ΑΝ

φόρος <- χρέωση * 0.02

ΦΠΑ <- χρέωση * 0.19

χρέωση <- χρέωση + φόρος + ΦΠΑ

ΓΡΑΨΕ 'Ο πελάτης ', όνομα, ' οφείλει ', χρέωση

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ HoeL-telefon

[Κλιμακούμενη]

Ένα τυπογραφείο έχει το εξής κοστολόγιο

Είδος εκτύπωσης Επιφάνεια Κόστος

Ασπρόμαυρη μέχρι 250 τ. εκ. 0.35 € ανά τ. εκ.

πάνω από 250 τ. εκ. 0.45 € ανά τ. εκ.

Έγχρωμη μέχρι 150 τ. εκ. 0.55 € ανά τ. εκ.

από 150 τ. εκ. μέχρι 850 τ. εκ. 0.70 € ανά τ. εκ.

πάνω από 850 τ. εκ. 0.88 € ανά τ. εκ.

Να αναπτύξετε πρόγραμμα που θα διαβάζει το είδος και την επιφάνεια της εκτύπωσης και θα εκτυπώνει το κόστος της αν υπάρχει και επιβάρυνση φόρου 4 %.

Λύση

ΠΡΟΓΡΑΜΜΑ Τυπογραφείο

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: επιφάνεια

ΠΡΑΓΜΑΤΙΚΕΣ: κόστος

ΧΑΡΑΚΤΗΡΕΣ: είδος

ΑΡΧΗ

ΔΙΑΒΑΣΕ είδος, επιφάνεια ! η επιφάνεια μετριέται σε τ. εκ.

ΑΝ είδος = 'Ασπρόμαυρη' ΤΟΤΕ

ΑΝ επιφάνεια <= 250 ΤΟΤΕ

κόστος <- 0.35 * επιφάνεια

ΑΛΛΙΩΣ ! επιφάνεια > 250

κόστος <- 0.45 * επιφάνεια

ΤΕΛΟΣ_ΑΝ

ΑΛΛΙΩΣ ! είδος = ‘Έγχρωμη’

ΑΝ επιφάνεια <= 150 ΤΟΤΕ

κόστος <- 0.55 * επιφάνεια

ΑΛΛΙΩΣ_ΑΝ επιφάνεια <= 850 ΤΟΤΕ

κόστος <- 0.70 * επιφάνεια

ΑΛΛΙΩΣ ! ύψος > 1.90

κόστος <- 0.88 * επιφάνεια

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ

κόστος <- κόστος + 0.04 * κόστος

ΓΡΑΨΕ 'Το ποσό που πρέπει να καταβληθεί είναι ', κόστος

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Τυπογραφείο

 

 

span style=