Αρχική ΑΕΠΠ - Δομές Δεδομένων Λειτουργικά Συστήματα Δίκτυα Υπολογιστών ΙΙ Βάσεις Δεδομένων Παιδαγωγικά - Διδακτική

Βασικές Έννοιες

Μεταβλητή - Έκφραση Δομή Ακολουθίας Δομή Επιλογής Δομή Επανάληψης

Αναπαράσταση Αλγορίθμων

Διάγραμμα Ροής

Πίνακας Τιμών

Πίνακες

Μονοδιάστατοι Δισδιάστατοι Πολυδιάστατοι Αναζήτηση Ταξινόμηση Στοίβα Ουρά

Υποπρογράμματα

Συναρτήσεις Διαδικασίες Σχετικά με τις παράμετρους

Δυναμικές Δομές

Λίστες Δέντρα Γράφοι

 Ιστορικό Πρόσφατες αλλαγές Εκτύπωση Αναζήτηση

Από το βιβλίο ΑΕΠΠ: Η ακολουθιακή δομή εντολών (σειριακών βημάτων) χρησιμοποιείται πρακτικά για την αντιμετώπιση απλών προβλημάτων, όπου είναι δεδομένη η σειρά εκτέλεσης ενός συνόλου ενεργειών. Ένα απλό παράδειγμα από την καθημερινή ζωή είναι η ακολουθία οδηγιών μίας συνταγής μαγειρικής με στόχο την κατασκευή ενός φαγητού. Τα βήματα και οι ποσότητες που πρέπει να ακολουθηθούν είναι συγκεκριμένα και οι οδηγίες απόλυτα καθορισμένες και σαφείς.

Σημαντικότητα Σειράς Εντολών

Σε ορισμένες διαδικασίες (από εδώ και μετά αλγόριθμοι) δεν έχει σημασία η σειρά των βημάτων (από εδώ και μετά εντολές) ή μερικών από αυτά για το τελικό αποτέλεσμα. Δηλαδή, θα έχουμε το ίδιο αποτέλεσμα ακόμη και αν δεν διατηρηθεί η σειρά που περιγράφεται.

Παράδειγμα: Να διαβαστούν δύο αριθμοί και να εμφανισθεί το αποτέλεσμα της πρόσθεσής τους.

  1. ΠΡΟΓΡΑΜΜΑ ΠΑΡΑΔΕΙΓΜΑ
  2. ΜΕΤΑΒΛΗΤΕΣ
  3.   ΑΚΕΡΑΙΕΣ: Α, Β, Χ
  4. ΑΡΧΗ
  5.   ΔΙΑΒΑΣΕ Α
  6.   ΔΙΑΒΑΣΕ Β
  7.   Χ <- Α - Β
  8.   ΓΡΑΨΕ Χ
  9. ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Στο παραπάνω πρόγραμμα δεν έχει σημασία αν θα διαβαστεί πρώτα αριθμός για την μεταβλητή Α (γραμμή 5) ή για τη μεταβλητή Β (γραμμή 6). Μπορεί, δηλαδή, να προηγηθεί η γραμμή 6 της γραμμής 5 αλλάζοντάς τους σειρά στο πρόγραμμα.

Τις περισσότερες φορές όμως έχει σημασία η σειρά με την οποία εμφανίζονται οι εντολές του προγράμματος. Σε περίπτωση που δεν ακολουθηθεί το αποτέλεσμα είναι τελείως διαφορετικό από εκείνο που περιμένουμε.

Παράδειγμα: Να διαβαστούν δύο αριθμοί και να εμφανισθεί το αποτέλεσμα της αφαίρεσής τους.

  1. ΠΡΟΓΡΑΜΜΑ ΠΑΡΑΔΕΙΓΜΑ
  2. ΜΕΤΑΒΛΗΤΕΣ
  3.   ΑΚΕΡΑΙΕΣ: Α, Β, Χ
  4. ΑΡΧΗ
  5.   ΔΙΑΒΑΣΕ Α
  6.   ΔΙΑΒΑΣΕ Β
  7.   Χ <- Α - Β
  8.   ΓΡΑΨΕ Χ
  9. ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Σ' αυτό το πρόγραμμα είναι προφανές ότι αν αλλάξει η σειρά εκτέλεσης των εντολών στις γραμμές 5 και 6, το αποτέλεσμα δε θα είναι το ίδιο αφού αλλάζει ο αφαιρετέος και ο αφαιρέτης.

Πρέπει, λοιπόν, ακόμη και σε απλούς αλγόριθμους να είμαστε σίγουροι ότι τα βήματά μας οδηγούν στην επιθυμητή λύση.


Ασκήσεις

Τελευταία ενημέρωση: 11-02-2008 (19:06)

Copyright 2008 - Άρης Φεργάδης