Αρχική ΑΕΠΠ - Δομές Δεδομένων Λειτουργικά Συστήματα Δίκτυα Υπολογιστών ΙΙ Βάσεις Δεδομένων Παιδαγωγικά - Διδακτική

Βασικές Έννοιες

Μεταβλητή - Έκφραση Δομή Ακολουθίας Δομή Επιλογής Δομή Επανάληψης

Αναπαράσταση Αλγορίθμων

Διάγραμμα Ροής

Πίνακας Τιμών

Πίνακες

Μονοδιάστατοι Δισδιάστατοι Πολυδιάστατοι Αναζήτηση Ταξινόμηση Στοίβα Ουρά

Υποπρογράμματα

Συναρτήσεις Διαδικασίες Σχετικά με τις παράμετρους

Δυναμικές Δομές

Λίστες Δέντρα Γράφοι

 Ιστορικό Πρόσφατες αλλαγές Εκτύπωση Αναζήτηση

Η δομή επιλογής καλύπτει την περίπτωση όπου πρέπει να πάρουμε μία απόφαση με βάση την τιμή μίας ή περισσότερων μεταβλητών. Το βιβλίο της ΑΕΠΠ κάνει έναν διαχωρισμό των δομών επιλογών με βάση τις συνθήκες που μπορούμε να έχουμε. Έτσι, όταν ελέγχουμε μία μόνο συνθήκη, έχουμε δομή επιλογή και όταν ελέγχουμε περισσότερες από μία, έχουμε διαδικασίες πολλαπλών επιλογών.

Ας δούμε τις εντολές και τη σύνταξη που χρησιμοποιούμε στη δομή επιλογής.

Σύνταξη
ΑΝ συνθήκη ΤΟΤΕ
  εντολή-1
  εντολή-2
  ...
  εντολή-ν
ΑΛΛΙΩΣ
  εντολή-α
  εντολή-β
  ...
  εντολή-x
ΤΕΛΟΣ_ΑΝ
Παράδειγμα
ΑΝ αριθμός > 0 ΤΟΤΕ
  ΓΡΑΨΕ 'Ο αριθμός είναι θετικός'
  Θετικοί <- Θετικοί + 1
ΑΛΛΙΩΣ
  ΓΡΑΨΕ 'Ο αριθμός είναι αρνητικός'
ΤΕΛΟΣ_ΑΝ
Λειτουργία
Αν η συνθήκη ισχύει, τότε εκτελούνται οι εντολές που βρίσκονται μεταξύ των λέξεων ΤΟΤΕ και ΑΛΛΙΩΣ, διαφορετικά εκτελούνται οι εντολές μεταξύ ΑΛΛΙΩΣ και ΤΕΛΟΣ_ΑΝ. Η εκτέλεση του προγράμματος συνεχίζεται με την εντολή που ακολουθεί τη δήλωση ΤΕΛΟΣ_ΑΝ.

Λογική Συνθήκη

Η λογική συνθήκη είναι μία έκφραση η οποία μπορεί να πάρει μόνο δύο τιμές: το λογικό ΑΛΗΘΗΣ και το λογικό ΨΕΥΔΗΣ. Στη ΓΛΩΣΣΑ δεν μπορούμε να χρησιμοποιήσουμε τον τελεστή εκχώρησης στη λογική συνθήκη. Σε άλλες γλώσσες προγραμματισμού, όπως η C, μπορούμε να έχουμε και εντολή εκχώρησης στην συνθήκη. Έτσι, για τη ΓΛΩΣΣΑ θα χρησιμοποιούμε μόνο τους τελεστές ισότητας (=) και ανισότητας (<. <=, =>, >, <> - διαφορετικό).


Ασκήσεις

Τελευταία ενημέρωση: 09-02-2008 (18:59)

Copyright 2008 - Άρης Φεργάδης