Αρχική ΑΕΠΠ - Δομές Δεδομένων Λειτουργικά Συστήματα Δίκτυα Υπολογιστών ΙΙ Βάσεις Δεδομένων Παιδαγωγικά - Διδακτική

Βασικές Έννοιες

Μεταβλητή - Έκφραση Δομή Ακολουθίας Δομή Επιλογής Δομή Επανάληψης

Αναπαράσταση Αλγορίθμων

Διάγραμμα Ροής

Πίνακας Τιμών

Πίνακες

Μονοδιάστατοι Δισδιάστατοι Πολυδιάστατοι Αναζήτηση Ταξινόμηση Στοίβα Ουρά

Υποπρογράμματα

Συναρτήσεις Διαδικασίες Σχετικά με τις παράμετρους

Δυναμικές Δομές

Λίστες Δέντρα Γράφοι

 Ιστορικό Πρόσφατες αλλαγές Εκτύπωση Αναζήτηση

Η δομή επανάληψης επιτρέπει την εκτέλεση των εντολών, που βρίσκονται μέσα στο βρόχο της επανάληψης, περισσότερες από μία φορά. Οι επαναλήψεις ελέγχονται πάντα από συνθήκη η οποία και καθορίζει την έξοδο από το βρόχο.

ΟΣΟ

ΜΕΧΡΙΣ_ΟΤΟΥ

ΓΙΑ

Σύνταξη

ΓΙΑ μεταβλητή ΑΠΟ αρχική τιμή ΜΕΧΡΙ τελική τιμή ΜΕ_ΒΗΜΑ βήμα
  εντολή-1
  εντολή-2
  …
  εντολή-ν
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Παράδειγμα:
ΠΡΟΓΡΑΜΜΑ ΑΘΡΟΙΣΜΑ_ΠΕΡΙΤΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Αριθμό, Άθροισμα
ΑΡΧΗ
  Άθροισμα <- 0
  ΓΙΑ Αριθμό ΑΠΟ 1 ΜΕΧΡΙ 100 ΜΕ_ΒΗΜΑ 2
    Άθροισμα <- Άθροισμα + Αριθμό
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Λειτουργία

Οι εντολές του βρόχου εκτελούνται για όλες τις τιμές της μεταβλητής από την αρχική τιμή μέχρι την τελική τιμή, μεταβαλλόμενες με την τιμή του βήματος. Αν το βήματα εί-ναι ίσο με 1, τότε παραλείπεται.

Μονός Βρόχος

Όταν αναφερόμαστε σε μονό βρόχο, εννοούμε ότι έχουμε έναν βρόχο ΓΙΑ του οποίου καμία από τις εντολές του δεν είναι βρόχος.

Όλες οι παρακάτω ενότητες διαχειρίζονται μονό βρόχο.

Διάγραμμα Ροής

Το διάγραμμα ροής είναι ίδιο με της δομής επανάληψης ΟΣΟ. Αυτό σημαίνει ότι για να φτιάξουμε το διάγραμμα πρέπει

  • να μετατρέψουμε τη δομή επανάληψης ΓΙΑ σε δομή επανάληψης ΟΣΟ
  • να φτιάξουμε το διάγραμμα όπως αναφέρεται στο διάγραμμα ροής για την ενότητα ΟΣΟ

Περιπτώσεις Ασκήσεων

Ακολουθούν χαρακτηριστικές περιπτώσεις ασκήσεων εξοικείωσης με τον βρόχο ΓΙΑ.

Πλήθος Επαναλήψεων Βρόχου

Πόσες φορές θα εκτελεστούν οι επαναληπτικές δομές στα παρακάτω τμήματα αλγορίθμων;

Για i από 1 μέχρι 3

	Εκτύπωσε "*"

Τέλος_Επανάληψης

Εμφάνιση Απάντησης

Το i θα πάρει τις τιμές: 1, 2, 3. Άρα 3 επαναλήψεις

Για i από 1 μέχρι 3 με_βήμα 0.5

	Εκτύπωσε "*"

Τέλος_Επανάληψης Το i θα πάρει τις τιμές: 1, 1.5, 2, 2.5, 3. Άρα 5 επαναλήψεις Για i από 3 μέχρι 1 με_βήμα -1

	Εκτύπωσε "*"

Τέλος_Επανάληψης Το i θα πάρει τις τιμές: 3, 2, 1. Άρα 3 επαναλήψεις Για i από 3 μέχρι 1 με_βήμα -0.5

	Εκτύπωσε "*"

Τέλος_Επανάληψης Το i θα πάρει τις τιμές: 3, 2.5, 2, 1.5, 1. Άρα 5 επαναλήψεις Για i από -3 μέχρι -1

	Εκτύπωσε "*"

Τέλος_Επανάληψης

	Το i θα πάρει τις τιμές: -3, -2, -1. Άρα 3 επαναλήψεις

Για i από -1 μέχρι -3 με_βήμα -0.5

	Εκτύπωσε "*"

Τέλος_Επανάληψης Το i θα πάρει τις τιμές: -1, -1.5, -2, -2.5, -3. Άρα 5 επαναλήψεις Για i από 1 μέχρι 3 με_βήμα -1

	Εκτύπωσε "*"

Τέλος_Επανάληψης Το i ξεκινάει από το 1 και μειώνεται σε κάθε βήμα κατά 1. Με αυτό τον τρόπο δε θα φτάσει ποτέ στο 3. Άρα ο αλγόριθμος αυτός θα εκτελείται επ’ άπειρο.

Δημιουργία Πίνακα Τιμών

Εύρεση Λαθών στον Κώδικα


Ασκήσεις?

Τελευταία ενημέρωση: 19-02-2008 (14:26)

Copyright 2008 - Άρης Φεργάδης